Korrektur: Nexus Mod Manager konnte keine Versionsinformationen vom Update-Server abrufen

Advise: Klicken Sie Hier, Windows-Fehler Und Optimiert Die Systemleistung Zu Beheben

Nexus Mod Manager ist ein Open Source-Programm für Nexus Mods. Das Programm ist für Windows verfügbar und ermöglicht es den Benutzern, Modifikationen automatisch herunterzuladen und in ihre Spiele zu implementieren. In letzter Zeit sind jedoch zahlreiche Berichte von Benutzern eingegangen, die keine Aktualisierungen für die Anwendung abrufen können. Die Anwendung zeigt den Fehler „Nexus Mod Manager Updater: Versionsinformationen konnten nicht vom Update-Server abgerufen werden“ an, während versucht wird, eine Aktualisierung durchzuführen.

Die Fehlermeldung "Updates fehlgeschlagen".

Was verursacht den Update-Fehler für Nexus Mod Manager?

Nach unserer Untersuchung der Angelegenheit haben wir eine Reihe von Lösungen entwickelt, die den Fehler für die meisten unserer Benutzer beheben. Außerdem haben wir uns mit den Ursachen des Problems befasst. Einige der häufigsten sind unten aufgeführt.

  • Administratorrechte: In einigen Fällen kann dieser Fehler auftreten, wenn die Anwendung nicht über ausreichende Berechtigungen verfügt. Wenn der Launcher versucht, Kontakt mit den Servern aufzunehmen und auf die Festplatte zu schreiben, verhindern unzureichende Berechtigungen dies.
  • Firewall: Manchmal verhindert die Windows-Firewall, dass bestimmte Elemente der Anwendung Kontakt mit den Servern aufnehmen. Dies kann verhindern, dass der Client aktualisiert wird, was zu diesem Fehler führt.
  • Protokollfehler: In früheren Versionen der Anwendung wurde das HTTP-Protokoll verwendet. In den neueren Versionen wird jedoch das HTTPs-Protokoll verwendet. Das HTTPs-Protokoll ist aufgrund der kürzlich in Europa erlassenen Gesetze erforderlich, aufgrund derer alle Websites das HTTPs-Protokoll verwenden müssen. Nexus Mods wurden ebenfalls auf das HTTPs-Protokoll aktualisiert. Daher können die älteren Versionen der Anwendung keine Verbindung mehr herstellen.
  • Veraltete Anwendung: In einigen Fällen wurde dieser Fehler auch bei neueren Versionen der Anwendung gemeldet. Daher wurde eine neue Version der Anwendung veröffentlicht, um diesen Fehler zu beheben. Die Nexus Mods-Website hat jedoch ihre Datenbank nicht auf die neuere Version der Anwendung aktualisiert. Das Update ist jedoch auf der Git Hub-Website verfügbar.

Nachdem Sie ein grundlegendes Verständnis für die Art des Problems haben, werden wir uns den Lösungen zuwenden. Es ist wichtig, dass Sie diese Lösungen in der angegebenen Reihenfolge implementieren.

Lösung 1: Gewähren von Administratorrechten.

In einigen Fällen kann dieser Fehler auftreten, wenn die Anwendung nicht über ausreichende Berechtigungen verfügt. Wenn der Launcher versucht, Kontakt mit den Servern aufzunehmen und auf die Festplatte zu schreiben, verhindern unzureichende Berechtigungen dies. Daher werden wir in diesem Schritt der Anwendung Administratorrechte erteilen. Dafür:

  1. Klicken Sie mit der rechten Maustaste auf die ausführbare Datei der Anwendung .
  2. Wählen Sie „ Eigenschaften “.
  3. Klicken Sie auf die Registerkarte " Kompatibilität " und aktivieren Sie das Kontrollkästchen " Als Administrator ausführen ".
  4. Versuchen Sie, die Anwendung auszuführen, und überprüfen Sie, ob das Problem weiterhin besteht.

    Bereitstellen von Administratorrechten.

Lösung 2: Gewähren des Zugriffs in der Firewall.

Manchmal verhindert die Windows-Firewall, dass bestimmte Elemente der Anwendung Kontakt mit den Servern aufnehmen. Dies kann verhindern, dass der Client aktualisiert wird, was zu diesem Fehler führt. In diesem Schritt gewähren wir der Anwendung daher einen Ausschluss in der Windows-Firewall. Dafür:

  1. Klicken Sie auf das Startmenü und wählen Sie das Symbol " Einstellungen ".
  2. Klicken Sie in den Einstellungen auf die Option " Updates & Sicherheit ".
  3. Wählen Sie im linken Bereich die Option „ Windows-Sicherheit “.
  4. Klicken Sie auf die Option " Firewall & Netzwerkschutz ".
  5. Wählen Sie die Option " Anwendung durch Firewall zulassen ".
  6. Klicken Sie auf " Einstellungen ändern ", um die erforderlichen Berechtigungen zu erteilen .
  7. Erlaube " Nexus Mod Manager " und alle NMM- bezogenen Anwendungen über " öffentliche " und " private " Netzwerke.
  8. Klicken Sie auf „ OK “, führen Sie die Anwendung aus und prüfen Sie, ob das Problem weiterhin besteht.

    Zulassen einer Anwendung über die Firewall.

Lösung 3: Aktualisieren der Anwendung.

Bei der älteren Version der Anwendung ist ein Fehler aufgetreten, aufgrund dessen der Fehler ausgelöst wurde. Außerdem verwendeten die älteren Versionen der Anwendung das HTTP-Protokoll anstelle des HTTPs-Protokolls. Da die Nexus Mods ihre Server auf das HTTP-Protokoll umgestellt haben, wurden die älteren Versionen unbrauchbar. Daher werden wir in diesem Schritt beide Probleme beheben, indem wir die Anwendung auf die neueste Version aktualisieren.

  1. Deinstalliere den Nexus Mod Manager .
  2. Klicken Sie hier, um die neueste Version der Anwendung herunterzuladen .
  3. Nach dem Herunterladen installieren Sie die Anwendung.

    Anwendung installieren.
  4. Versuchen Sie, den Nexus Mod Manager auszuführen und zu überprüfen, ob das Problem weiterhin besteht.

Interessante Artikel